• Esta dirección de correo electrónico está siendo protegida contra los robots de spam. Necesita tener JavaScript habilitado para poder verlo.
Preséntate a la comunidad

Desde San Luis...

Desde San Luis... Publicado por Jorge

Posted 5 años 3 meses antes #1661
Buen dia y gracias por aceptarme. Hace unos años arme una impresora tipo Prusa i3con placas Mega 2560 / Ramps 1.4 que funciono como era de esperar por ser mi primera experiencia.
Por diversos motivos, quedo archivada y he decidido volverla a la accion, limpiarla, alinear guias, reacondicionar extruder e incluirle un lcd que estaba guardado desde un principio, sin uso.

Habiendo leido instrucciones para activar el LCD ( Reprap Discount Smart Controller XXL ) , intente hacerlo...cometiendo el error de modificar y subir un config.h ...que no era el de la maquina en uso, sino uno virgen, de uno de los ejemplos descargados !!!...Mi error de la semana !.
Hace 2 dias he intentado reconfigurarla, ( ni hablar del LCD todavia ), sin exito.

Problemas detectados

al intentar mover manualmente con Pronterfase : los 3 motores ( X, Y y Z )actuan en direccion a +x, +y ,+z... pero no retroceden. Como si quedara definido home en el punto alcanzado.

Si bien defini HOME con -1,-1,-1....(Min adelante a la izquierda )...al teclear Home... los 3 motores avanzan ! alejandose de los limites de cero.

A partir de aqui, los contacto para ver si me pueden indicar, u orientar ya que algo se me esta escapando y no lo veo...

Adjunto el archivo config.h actual.
Donde esta el error ??? Firmware o hardware...? Como puedo corregirlo ?

Desde ya muchas gracias.
Jalex desde San Luis
Post by Jorge

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Respuesta de Jorge sobre el tema Desde San Luis...( 2 )

Posted 5 años 3 meses antes #1662
adjunto archivo zip.... anterior .rar no lo acepto el foro...
Post by Jorge

Este mensaje tiene un archivo adjunto.
Por favor iniciar sesión o registrarse para verlo.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Respuesta de Jorge sobre el tema Desde San Luis...

Posted 5 años 3 meses antes #1664
Este archivo está oculto a usuarios invitados.
Por favor, inicie sesión o regístrese para verlo.
Post by Jorge

Este mensaje tiene un archivo adjunto.
Por favor iniciar sesión o registrarse para verlo.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Respuesta de Raúl Diosdado sobre el tema Desde San Luis...

Posted 5 años 3 meses antes #1665
Hola Jorge, no conozco el modelo de impresora que tienes, he estado viendo el código que has adjuntado y hay algunas cosas que me parece raro como están configuradas, pero sin conocer bien tu impresora no me atrevo a decirte que las cambies....
Te adjunto el Marlín que tengo en los tutoriales para que pruebes a ver que tal te va (suele funcionar con la mayoría de los modelos de impresora) retocale las cosas que veas que están mal como el modelo de la tarjeta o si usas algún termistor diferente del configurado. Dime que tal te va y a partir de ahi vamos configurando.
Lo que me ha parecido mas raro es lo que comentas que al avanzar no te deja retroceder... esto no es normal, lo que suele pasar al encender la impresora es que el punto en el que se enciende lo toma como HOME, si no se hace un HOMING no te va a dejar ir en negativo desde ese punto, pero si avanzas debe dejarte retroceder al menos lo que has avanzado.
Cuando lo cargues dime lo que sea y vamos avanzando solucionando cosillas.
Marlin
Post by Raúl Diosdado

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Respuesta de Jorge sobre el tema Desde San Luis...

Posted 5 años 3 meses antes #1672
Buen dia Raul.... antes que nada, muchas gracias por tu respuesta.
Te cuento que despues de pasarme viernes y medio sabado leyendo, tocando y probando... pude hacer funcionar los motores como corresponde, o sea en ambas direcciones y no solo hacia adelante.

El cambio fue " false por true " en la logica de los endswitchs...a partir de eso, con el Pronterface los puedo mover en ambas direcciones y al dar home... retroceden en vez de avanzar !

Ademas, tambien pude hacer funcionar la LCD , asi que sigo con los proximos pasos de la restauracion de esta maquinita casera, despues de de 6 años de inactividad !..

Aca fue lo cambiado...
// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.
const bool X_ENDSTOPS_INVERTING = false; // set to true to invert the logic of the endstops.
const bool Y_ENDSTOPS_INVERTING = false; // set to true to invert the logic of the endstops.
const bool Z_ENDSTOPS_INVERTING = false; // set to true to invert the logic of the endstops.
//#define DISABLE_MAX_ENDSTOPS

Pregunta siguiente... es posible ver los renglones/ instrucciones del Marlin numeradas , para encontralas facilmente ??? Como o por donde se hace ???

Gracias por tu tiempo y disposicion !
Un saludo desde San Luis
Jorge A.
Post by Jorge

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Respuesta de Raúl Diosdado sobre el tema Desde San Luis...

Posted 5 años 3 meses antes #1675
Buenos días, me alegro que estés solucionando los problemas de la impresora, veras como en poco tiempo la tienes a punto.
En cuanto a lo que me comentas de si se pueden ver los renglones numerados, la respuesta es no, si usas el IDE de Arduino es bastante complejo moverse cuando tienes mucho código, ya que como tu dices no se encuentran fácilmente las cosas. Yo para editar código o buscar palabras dentro de un programa uso el notepad++, te dejo el enlace ( Notepad++https://notepad-plus-plus.org /) este programa a no sirve para cargar el código en Arduino, pero si para modificar el programa, buscar palabras o código y para abrir infinidad de documentos, a mi me es muy útil. Espero que te sirva a ti también.
Post by Raúl Diosdado
El siguiente usuario dijo gracias: Jorge

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Tiempo de carga de la página: 1.732 segundos